HostAP and xsupplicant

Dimitris Theofilatos thed at intracom.gr
Tue Jan 14 06:18:42 EST 2003


Hi,

The problem still exists with older version of xsupplicant.
I think that it is not a problem of xsupplicant but a problem of Host AP (or i 
am doing something wrong).
I believe so, because when i follow the next steps:
make plx EXTRA_CFLAGS="-DPRISM2_HOSTAPD"
make install_plx
modprobe hostap_plx
cd hostapd
make
./hostapd wlan0
which means that i dont use 802.1x (am i correct?) the mobile station becomes 
authenticated and associated but i can't make a ping from the mobile station 
to the access point.
When i follow the next steps (not 802.1x functionality):
make plx
make install_plx
modprobe hostap_plx
everything works fine.
I use a 3COM 3CRWE777A-E1 card at the access point and a Orinoco silver card 
at the mobile station.
Thanks
Dimitris

> On Mon, Jan 13, 2003 at 03:13:25PM +0000, Dimitris Theofilatos wrote:
> > Does anyone know if the HostAP code interworks with the xsupplicant code
> > from open1x? I followed the instructions from the site
> > www.missl.cs.umd.edu/wireless/eaptls/. I used 3 linux machines with
> > RedHat 7.3 and kernel 2.4.18. I used hostap-2002-10-12 driver and the
> > latest version of xsupplicant (xsupplicant-0.5)  but when the xsupplicant
> > sends the first EAPOL Start message the hostapd daemon unauthorize the
> > station.
>
> I tested xsupplicant v0.5 today, but it segfaulted when I tried to
> authenticate.. I didn't yet have time to check why. Anyway, older
> version of xsupplicant work fine with the same certificates and
> configuration using hostapd as Authenticator and FreeRADIUS as
> Authentication Server.
>
> Authenticator state machines set the port into unauthorized state when a
> new station is added so it is OK to get that messages after EAPOL-Start.
> The port is authorized for the first time only after successful
> authentication has been completed.





More information about the HostAP mailing list