2002-10-12 monitor mode

Jouni Malinen jkmaline at cc.hut.fi
Mon Jan 13 00:37:02 EST 2003


On Tue, Dec 10, 2002 at 11:57:48AM -0500, Bichot Guillaume (Princeton) wrote:

> I found that some time, switching to the monitor mode, the incoming frames
> are wrong. I mean running wlansniff I found that there is a shift in the
> data packet delivered to the user space in such a way the wlansniff
> misinterprets the header. Ethereal is also unable to interprets correctly
> the frames as well. To solve the problem I have to switch back to the
> managed mode and switch back to the monitor mode (need sometime several back
> and forth until the things go right). I have to add that I use the monitor
> mode with the frequency I want to listen (i.e. iwconfig wlan0 freq
> "2.437ghz" mode "monitor").

Can you repeat this easily? With current CVS version of Host AP driver?
If yes, could you please describe all commands you used to change the
card into monitor mode up to the point when you received invalid frames?

I can think of only one way to get invalid frame for wlansniff (or
Ethereal) and that is to change the netdev type during sniffing session
(i.e., without restarting wlansniff). wlansniff does not update
interface type per packet, so it requires restarting. Other than this, I
haven't seen such errors with the latest driver version.

> I'm using the Linksys WPC 11 PCMCIA card (manfid 0x274, 0x1613).

Today I did some testing with the same card model (and STA f/w 1.4.9 and
latest CVS version of Host AP driver) and was unable to duplicate this.

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list