debian 3.0 kernel 2.4.20 hostap wep problem

Jeetendra Kumar jeetendra at alumnux.com
Fri Feb 28 06:15:44 EST 2003


Hi Paul,
I feel you also take help of README.prism2. It explains the required 
configuration for setting up WEP. It also outlines the limitation of the 
present implementation.

Thanks,
Jeetendra

Paul Vanovertveld wrote:

> Jeetendra Kumar wrote:
>
>> Hi Paul,
>> Please check if you have hostap_crypt_wep.o module. Also check if you 
>> have hostap_crypt_wep.c in the source tree. Hope this helps,
>>
>> Thanks,
>> Jeetendra
>>
>> Paul Vanovertveld wrote:
>>
>>> Hello,
>>>
>>> I am using debian 3.0, from the testing tree I grabbed the 
>>> hostap-source. After compiling an new kernel, pcmcia-module and 
>>> hostap I am able to run my little AP. I am using a Netgear 401 
>>> PCMCIA Card (Firmware 1.3.4) Everything works fine, but when I try 
>>> to enable WEP I get the following error
>>>
>>> # iwconfig wlan0 s:12345
>>> wlan0: could not initialize WEP: load module hostap_crypt_wep.o
>>> Error for wireless request "Set Encode" (8B2A) :
>>>     SET faild on device wlan0 ; Operation not supported.
>>>
>>>
>>> This is strange, because on an W2k laptop WEP is working and when I 
>>> use the orinoco driver I am also able to use WEP.
>>> Any ideas? It is more than possible that I made something wrong :-)
>>>
>>>
>>> thanks in Advance
>>>
>>> Paul
>>>
>>> _______________________________________________
>>> HostAP mailing list
>>> HostAP at shmoo.com
>>> http://lists.shmoo.com/mailman/listinfo/hostap
>>
>>
>>
>>
> Thanks,
>
> checked both are there.  :-(


-- 

------------------------------------
    _    Jeetendra Kumar           |
   °v°   Alumnus Software Limited  |
  /(_)\  Kolkata, India - 700091   |
   ^ ^   http://www.alumnux.com    |
------------------------------------






More information about the HostAP mailing list