netperf BW tests with hostap and wlan-ng on WL200

JuanJo Ciarlante jjo-hostap at mendoza.gov.ar
Wed Feb 26 09:45:31 EST 2003


On Tue, Feb 25, 2003 at 08:19:59PM -0800, Jouni Malinen wrote:
> On Tue, Feb 25, 2003 at 02:21:06PM -0500, Zhang, Tiebing wrote:
> 
> > The hostap driver in April 2002(still in old structure) has addressed this
> > issue. In function hfa384x_setup_bap() of prism2.c, disabling-interrupt (
> > function cli() ) was added. However, this code was removed after June 2002
> > in a code cleanup. I have personally kept this and no reset has been spotted
> > since then. 
> > 
> > I think Jouni is the best person to explain why that part of the code was
> > removed.
> 
> It was supposed to not be needed anymore with the current scheme of
> using BAP (only one BAP is used).

I do confirm that bringing back cli/sti (actually a local 
spin_lock_irqsave/spin_unlock_irqrestore pair) had made resets  dissappear
during a TX stress test (netperf -l99 ...); although BW have increased, 
it's still lower than wlanng.

> If it is still needed, there is
> something wrong with higher level locking. And yes, there probably is..

high level or low level ?
It seems to me that IRQ handling is "breaking" wait_offset() tight loop under
setup_bap() ...

> I have this in my todo list for testing, but I have been quite occupied
> with other projects lately so this has been delayed.

I can do further debugging/testing, this low powered CPU + Prism2 seems to
be a good combo to trigger these behaviour, just let me know.

Regards

-- 
--Juanjo

#  Juan Jose Ciarlante (JuanJo PGP) jjo ;at; mendoza.gov.ar              #
#  Key fingerprint = 76 60 A5 76 FD D2 53 E3  50 C7 90 20 22 8C F1 2D    #



More information about the HostAP mailing list