Bridging vs Nat

Mojo B. Nichols mojo.nichols at verizon.net
Tue Feb 25 08:40:19 EST 2003


James Harper <james.harper at bigpond.com> writes:

> Mojo B. Nichols wrote:
> 
> >James Harper <james.harper at bigpond.com> writes:

[snip]

> 
> >I do understand it to be that these cards and (dlink) are not highly
> >regarded, by the linux wireless community.  My understanding is that
> > there is general consensus that they are pieces of $#!&.
> 
> mine was horrible until i upgraded the firmware to 1.4.9. since then
> it runs very well.
> 

Hmmm I wonder if that is what mine needs, although I only purchased it
3 months ago. Sorry for the confusion I also have the dwl 520 pci
card, I put all my eggs in one basket and purchased both the dwl520
and the dwl620 based on reading that these were successfully installed.
But alas the new dwl620 are not actually dwl620.  I think that is
terribly dishonest, and am going to post to hostap in hopes that some
other poor bastard googles it and doesn't get duped.

> 
> >Personally, I'll never by a Dlink product again, but not because of this piece of
> >junk.  At the same time I purchased what I thought to be the dwl620,
> >but what was instead the a dwl620HB, and there is no support for it.
> >You can't even get pcmcia to identify it to be able to load a
> >driver:-( Big song and a dance they finally agreed to send me a new
> >card, but now I get no reply from them.  Jerks.
> >
> bought from dlink or a reseller? they are cheap, and you get what you
> pay for :) mine is the 520 which is native pci.

I purchased directly from there website.  I spoke directly with tech
support. I got them to agree to RMA the piece and send an actual
dwl620... but while waiting in RMA limbo, I went out and purchased an
Orinocco.

> 
> 
> >>when i look at the interrupt handling code for the hostap driver, it
> >>checks the SWSUPPORT0 register on any interrupt, before it even
> >>checks if the card itself owns the interrupt. i think this could
> >>cause bad things to happen but i'm not sure. i'll tinker with it if
> >>i get time and let you know.
> >>
> > That sounds like this could be our culprit... keep me informed.
> 
> i commented out the swsupport0 checking code (it's a pci card - it
> won't get removed) and there was no noticable effect. i won't do
> anything else  tonite, my wife is using my laptop and if i go
> rebooting the server (with the wireless card in it) she's likely to
> get annoyed :)

I believe I did the same with no effect.  I can fairly reliable say my lockup occurs in the 

prism2_alloc_ev that it occurs... I put printk statements before and
after the offending lines, and N-1 timmes out of N it works the Nth it
freezes.  The line occurs twice, I guess where it reads the registers.
I'm way in over my head here though, and my wife uses the laptop, and
it fairly reliable with NAT'ing it's only speaking directly to the
machine.  I wonder if it is volume related. 


Thanks again,


Mojo





More information about the HostAP mailing list