2.4.20 (WOLK) and hostap(d)

Carsten Otto c-otto at gmx.de
Tue Feb 4 15:17:22 EST 2003


Hello!

I am running 2.4.20-wolk4.0s (pre-pre10) and have problems to load the
hostap-modules. I compiled hostap.o, _pci, _plx, _crypt, _crypt_wep
and hostapd.o, but none of them starts.
After a "fresh" make hostapd in the hostapd-subdir and insmod
hostapd.o I get:

hostapd.o: couldn't find the kernel version the module was compiled for

A depmod -a (after installing the mentioned modules) gives:

depmod: *** Unresolved symbols in /lib/modules/2.4.20-wolk4.0s/net/hostap.o
depmod: *** Unresolved symbols in /lib/modules/2.4.20-wolk4.0s/net/hostap_pci.o
depmod: *** Unresolved symbols in /lib/modules/2.4.20-wolk4.0s/net/hostap_plx.o

insmod xxx/yyy/hostap.o:

/lib/modules/2.4.20-wolk4.0s/net/hostap.o: unresolved symbol wireless_send_event
/lib/modules/2.4.20-wolk4.0s/net/hostap.o: unresolved symbol hostap_get_crypto_ops_Re5a7eae9

The card is a pheenet PCI-card (worked with 2.4.19-kernel and hostap).

Please answer, if you know one or more of these errors or have any
other helpful clue.

Thanks!
Carsten Otto
PS: WOLK is at http://sourceforge.net/projects/wolk
Other specs:

http://c-otto.yi.org/phpsysinfo/

Duron 750, 320MB RAM, 28,5GB 7200rpm HDD, Intel Gigabit, Tulip
100MBit, Debian Woody with 2.4.20-wolk4.0s (pre-pre10) running

If you need more information just drop a mail.
-- 
Carsten Otto
c-otto at gmx.de
www.c-otto.de




More information about the HostAP mailing list