Primary Firmware Download

Pavel Roskin proski at gnu.org
Sun Aug 3 03:18:52 EDT 2003


On Sat, 2 Aug 2003, Jouni Malinen wrote:

> That guess was correct. I used to test Genesis mode with hostap_pci, but
> I decided to quickly test with hostap_cs. Everything started working
> suddenly :-). I was able to enable the Genesis mode and load Primary f/w
> to RAM. This forced me to finally fix PRI-only operation ;-). With this,
> I was able to load secondary f/w into RAM while the card was running in
> PRI-only mode. I have not yet tested, whether this works when PRI is
> actually loaded from flash, but I would assume it would work equally
> well.

Very impressive.  Now the world is a better place to live :-)

> I haven't yet fixed hostap_pci, so Genesis mode can now be used only
> with hostap_cs. However, PRI-only mode should work even with hostap_pci.
> I will take a look at fixing this. If someone is interested in working
> with this, the only missing part should be in adding
> prism2_pci_genesis_reset() into hostap_pci.c. hostap_plx can wait for
> the time being, since I do not have my PLX adapter easily available.

Well, I have a PLX card and I can put a Prism 2.5 card into it.  I also
have a PCI card that needs resurrection.

I'm not sure if you did something to allow the driver initialization to go
ahead if the FID allocation (or some other part of initialization) fails.
Right now, hostap_pci refuses to serve a card with STA 1.1.0.

By the way, the "idle" argument is unused and should be removed.  hcr
already determines if the card should be idle upon reset.

> > I downgraded my DWL-520 Rev. A to PRI 1.0.4, STA 1.1.0, but now
> > hostap_pci crashes on load.  That's a theme for a separate thread once
> > I do at least minimal debugging.
>
> I assume your patch fixed the crash. Do you know why that firmware
> combination does not work?

Yes, the crash is fixed now.  I don't know why it doesn't work.  I cannot
believe Intersil would release firmware that doesn't work at all.  Maybe
it's incompatible with PCI cards that appeared later.

On the other hand, I know a Prism2 (SMC 2632W) card that used to work
with STA firmware 0.7.6, but then "degraded" and worked only sporadically.
When I tried to update the firmware using prism2_srec, I saw exactly the
same error with allocating FIDs.  I had to use prism2dl to flash it.

Maybe older firmware has a problem with some parameters fluctuating with
time, temperature, radio interference or the phase of the Moon :-)

-- 
Regards,
Pavel Roskin



More information about the HostAP mailing list