hostap/utils/ & RedHat 7.3

da.silva at free.fr da.silva at free.fr
Sun Oct 27 10:04:08 EST 2002


With a RedHat 7.3 I have somme warmings/errors when compling utils :

cc -O2 -Wall -I/usr/src/linux/include   -c -o prism2_srec.o prism2_srec.c
In file included from /usr/src/linux/include/linux/wireless.h:70,
                 from prism2_srec.c:20:
/usr/src/linux/include/linux/ethtool.h:18: parse error before `u32'
/usr/src/linux/include/linux/ethtool.h:18: warning: no semicolon at end of 
struct or union
/usr/src/linux/include/linux/ethtool.h:19: warning: type defaults to `int' in 
declaration of `supported'
....
/usr/src/linux/include/linux/ethtool.h:243: parse error before `}'
make: *** [prism2_srec.o] Error 1

I have to touch some of hostap files :

 hostap/utils/util.h 
 hostap/utils/util.c
 hostap/utils/hostap_crypt_conf.c
 hostap/utils/prism2_srec.c

Here are the changes :


hostap/utils/util.h :
--------before--------
int hostap_ioctl_readmif(const char *dev, int cr);

#endif /* UTIL_H */
----------------------
--------after--------
int hostap_ioctl_readmif(const char *dev, int cr);

typedef unsigned long long u64;

#endif /* UTIL_H */
---------------------


hostap/utils/hostap_crypt_conf.c :
--------before--------
#include <linux/if_ether.h>
#include <linux/wireless.h>

#if WIRELESS_EXT < 9
#error "Linux Wireless Extensions version 9 or newer required"
#endif

typedef unsigned int u32;
typedef unsigned short u16;
typedef unsigned char u8;

#define DEFAULT_KEYS "ff:ff:ff:ff:ff:ff"
---------------------
--------after--------
#include <linux/if_ether.h>

typedef unsigned long long u64;
typedef unsigned int u32;
typedef unsigned short u16;
typedef unsigned char u8;

#include <linux/wireless.h>

#if WIRELESS_EXT < 9
#error "Linux Wireless Extensions version 9 or newer required"
#endif

#define DEFAULT_KEYS "ff:ff:ff:ff:ff:ff"
---------------------

hostap/utils/prism2_srec.c :
--------before--------
#include <sys/socket.h>
#include <linux/wireless.h>
#include <errno.h>

#if WIRELESS_EXT < 9
#error "Linux Wireless Extensions version 9 or newer required"
#endif

#include "util.h"


static int verbose = 0;
----------------------
--------after--------
#include <sys/socket.h>
#include "util.h"
#include <linux/wireless.h>
#include <errno.h>

#if WIRELESS_EXT < 9
#error "Linux Wireless Extensions version 9 or newer required"
#endif

static int verbose = 0;
---------------------


hostap/utils/util.c :
--------before--------

#include <linux/if_ether.h>
#include "util.h"
#include <linux/wireless.h>

#if WIRELESS_EXT < 9
#error "Linux Wireless Extensions version 9 or newer required"
#endif

struct hostap_nicid_rec {
---------------------
--------before--------
#include <linux/if_ether.h>
#include <linux/wireless.h>

#if WIRELESS_EXT < 9
#error "Linux Wireless Extensions version 9 or newer required"
#endif

#include "util.h"

struct hostap_nicid_rec {
---------------------



More information about the HostAP mailing list