0.7.5 to 1.4.9 firmware upgrade??

Pedro Estrela pedro.estrela at inesc.pt
Mon Oct 14 20:37:16 EDT 2002


Hello!

I've got the same problem, and i'm currently searching both the archives and
the developers websites for this information.

I have several compaq WL100 PCMCIA cards, based on Prism2 chipset (HFA3841,
NICID 0x8002). However, all the firmwares available at
http://www.netgate.com/support/prism_firmware are for the chipsets prism2.5
and prism3  (HFA3842, NICID 0x800A and higher).

I'm hoping that the firmware for the zoom card fixed by Alejandro Lamas
(http://hostap.epitest.fi/hostap/2002-08/1540.html) will work on the compaq
WL100 (and also WL200), as it is a prism2 card (HFA3841, NICID 0x8003)
(Alejandro: please confirm if you can).

To perform the actual flashing (tomorrow) I will be using the Intersil
windows utility (WinUpdate-0-5-1-0.exe) that is inside
(ftp://ftp.dlink.com/Wireless/DWL650/Firmware/dwl650_firmware_8c2.exe)  (see
http://hostap.epitest.fi/hostap/2002-07/1379.html)

Other option is to use the 1.3.4 firmware from netgear's MA401
(ftp://downloads.netgear.com/files/netgear1/MA401v200.zip) (see
http://hostap.epitest.fi/hostap/2002-07/1384.html)

As thus, i would ask the hostap users with ***prism2 chipset***, to confirm
both success and insucess experiences regarding the latest firmwares.

Thanks,
Pedro Estrela

----- Original Message -----
From: "Bruno Lopes F. Cabral" <bruno at openline.com.br>
To: <hostap at shmoo.com>
Sent: Monday, October 14, 2002 10:04 PM
Subject: 0.7.5 to 1.4.9 firmware upgrade??


> Hi there
>
> I have several USR2445 pccards, which are based on prism
> chipset with the following firmware info:
>
> wlan0: NIC: id=0x8002 v1.0.0
> wlan0: PRI: id=0x15 v0.3.0
> wlan0: STA: id=0x1f v0.7.5
>
> I'm using these cards with openap linux (on a USR2450
> AP), hostap driver version 2002-05-19, kernel 2.4.17
>
> hostap_cs: hostap_cs.c 0.0.0 2002-05-19 (SSH Communications Security Corp,
Joun)
> hostap_cs: (c) SSH Communications Security Corp <jkm at ssh.com>
> hostap_cs: index 0x01: Vcc 5.0, irq 3, io 0x0100-0x013f
> hostap_cs: Registered netdevice wlan0
>
> I'd like to know if it is possible/recommended to upgrade
> them to a newer firmware (i.e. 1.4.9) or it would be
> better to stick with the one it has now.
>






More information about the HostAP mailing list