Linksys WMP11 - no device found error

Nate Stuart newt at newtsplace.com
Mon Nov 25 10:45:25 EST 2002


I ran into the same thing. Linksys recently changed the chipset on the
card, and gave no warning, or revision change on their packaging to let
you know which chipset you are buying. Your card has the Broadcom chipset,
and from my understanding there are no linux drivers for it yet.

I returned mine and picked up a Netgear MA311 (I think thats the number,
don't have it in front of me) and it's been working great out of the box.
It was about the same price, after the mail in rebate.

HTH,
-Nate
www.newtsplace.com

Jharana Mehta said:
> HI,
> I have compiled the hostap_pci driver with kernel version 2.4.9. when i
> run modprobe hostap_pci with Linksys WMP11 card, i get the following
> error:
> /lib/modules/2.4.9/net/hostap_pci.o : init_module: no such device
> /lib/modules/2.4.9/net/hostap_pci.o : insmod
> /lib/modules/2.4.9/net/hostap_pci.o failed
>
> I have compiled my kernel with no SMP and no MODVERSIONS.
>
> I went through the mailing list and found that it has been suggested to
> run lspci to see if the pci card is being detected or not. here is the
> output of lspci on my m/c - it has a matrox vga card and 2 eepro100
> cards, so i think 00:09.0 is the WMP11 card -
> 00:00.0 Host bridge: Intel Corporation 440BX/ZX - 82443BX/ZX Host bridge
> (rev 02)
> 00:01.0 PCI bridge: Intel Corporation 440BX/ZX - 82443BX/ZX AGP bridge
> (rev 02)
> 00:07.0 ISA bridge: Intel Corporation 82371AB PIIX4 ISA (rev 02)
> 00:07.1 IDE interface: Intel Corporation 82371AB PIIX4 IDE (rev 01)
> 00:07.2 USB Controller: Intel Corporation 82371AB PIIX4 USB (rev 01)
> 00:07.3 Bridge: Intel Corporation 82371AB PIIX4 ACPI (rev 02)
> 00:09.0 Network controller: BROADCOM Corporation: Unknown device 4301
> (rev 02)
> 00:0b.0 Ethernet controller: Intel Corporation 82557 [Ethernet Pro 100]
> (rev 05)
> 00:0c.0 Ethernet controller: Intel Corporation 82557 [Ethernet Pro 100]
> (rev 05)
> 01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G100
> [Productiva] AGP (rev 02)
>
> can someone please help me make the WMP11 card work..
>
> regards,
> Jharana
>
> *********************************************************
> Disclaimer
>
> This message (including any attachments) contains
> confidential information intended for a specific
> individual and purpose, and is protected by law.
> If you are not the intended recipient, you should
> delete this message and are hereby notified that
> any disclosure, copying, or distribution of this
> message, or the taking of any action based on it,
> is strictly prohibited.
>
> *********************************************************
> Visit us at http://www.mahindrabt.com






More information about the HostAP mailing list