hostap with D-LINK DWL-650

Jouni Malinen jkmaline at cc.hut.fi
Thu Nov 21 10:47:52 EST 2002


On Thu, Nov 21, 2002 at 09:19:51AM +0100, msc1 at alu.um.es wrote:

> Hello, I have an AMD K6-2 with Red Hat 7.2, hostap-2002-10-12, an ISA-PCMCIA 
> adapter and a D-LINK DWL-650 wireless card. The driver compiles, but when the 
> computer starts, the driver do not start, and show this:

Please see FAQ #1:

1. What does "GetNextTuple: No more items" mean in hostap_cs
initialization?

This is one of the most often reported problems in getting the
hostap_cs.o driver working. It is usually reported for D-Link DWL-650
PC Card, e.g., on ISA-to-PCMCIA adapter. Later versions of the driver
report this also with "Vcc mismatch - skipping this entry".

Most common reason for getting this is a mismatch in voltage
configuration. The driver tries to make sure that the voltage (Vcc)
configuration in CIS and the slot match each other. It refuses to
initialize the card if the card CIS does not include a CFTABLE entry
with a matching Vcc value. This seems to be a problem for some cases
since the CIS is invalid or the reported voltage is incorrect.

As a workaround, the driver supports a module parameter ignore_cis_vcc
that can be used to skip this verification. This can be enabled by
setting ignore_cis_vcc=1 in /etc/pcmcia/hostap_cs.conf (commented
example line in the end of file). This can also be tested by manually
loading the module with 'modprobe hostap_cs ignore_cis_vcc=1' before
inserting the card).

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list