Problem(s) with a Compaq WL200

Ryan Abbenhuys sneeze at igreen.net
Mon Dec 16 03:47:02 EST 2002


I noticed the email from Jouni that mentioned WL200's have issues shutting
down and that you have to shutdown the interface first before shutting down
the system.  I'm running Redhat 8, PCMCIA Card Services 3.2.3 and kernel
build 2.4.18-18.8.0 on an SMP platform.

Can anyone tell me if I can use this line in the network.opts file in
/etc/pcmcia

# Extra stuff to do before shutting down the interface
    stop_fn () { return; }

If so what could I change this to in order to shutdown the interface to try
and stop the system hanging during shutdown?  If anyone can help me out but
needs some more info let me know and i'll do my best to provide it.

At the moment my WL200 seems to initialise fine with the latest CVS of the
HostAP driver. But when it comes to shutting down the system it dies when
trying to shutdown PCMCIA.  I then have to reboot and upon rebooting get the
following error when trying to start PCMCIA again

cs: unable to map card memory!
cs: unable to map card memory!
cs: unable to map card memory!
cs: unable to map card memory!
cs: unable to map card memory!
cs: unable to map card memory!
memory_cs: mem0: anonymous: unknown size

If I then stop and start PCMCIA it seems to work fine.


Here's the successful PCMCIA initialisation....

Linux PCMCIA Card Services 3.2.3
  kernel build: 2.4.18-18.8.0custom #2 SMP Sat Dec 14 07:30:59 EST 2002
  options:  [pci] [cardbus] [apm]
Intel ISA/PCI/CardBus PCIC probe:
  Ricoh RL5C475 rev 80 PCI-to-CardBus at slot 00:0a, mem 0x20000000
    host opts [0]: [isa irq] [io 3/6/1] [mem 3/6/1] [pci irq 18] [lat
32/176] [bus 2/5]
    PCI card interrupts, PCI status changes
  Cirrus PD6729 rev 00 PCI-to-PCMCIA at slot 00:0c, port 0xa800
    host opts [0]: [ring] [pci irq 16] [1/5/0] [1/20/0]
    host opts [1]: [ring] [pci irq 16] [1/5/0] [1/20/0]
    PCI card interrupts, PCI status changes
cs: memory probe 0x0d0000-0x0dffff: clean.
hostap_crypt: registered algorithm 'NULL'
hostap_cs: 0.0.0 CVS (Jouni Malinen <jkmaline at cc.hut.fi>)
hostap_cs: setting Vcc=33 (constant)
hostap_cs: CS_EVENT_CARD_INSERTION
prism2_config()
hostap_cs: setting Vcc=33 (from config)
Checking CFTABLE_ENTRY 0x01 (default 0x01)
Config has no IRQ info, but trying to enable IRQ anyway..
IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
io->flags = 0x0046, io.base=0x0000, len=64
cs: IO port probe 0x0100-0x04ff: excluding 0x290-0x297 0x378-0x37f
0x3c0-0x3df 0x4d0-0x4d7
cs: IO port probe 0x0298-0x0377: clean.
cs: IO port probe 0x0380-0x03bf: clean.
cs: IO port probe 0x03e0-0x04cf: clean.
cs: IO port probe 0x04d8-0x04ff: clean.
cs: IO port probe 0x0a00-0x0aff: clean.
cs: IO port probe 0x0c00-0x0cff: clean.
hostap_cs: index 0x01: Vcc 3.3, irq 16, io 0x0100-0x013f
hostap_cs: Registered netdevice wlan0
prism2_hw_init()
prism2_hw_config: initialized in 10101 iterations
wlan0: NIC: id=0x8002 v1.0.1
wlan0: PRI: id=0x15 v0.3.0
wlan0: STA: id=0x1f v1.4.9
wlan0: defaulting to bogus WDS frame as a workaround for firmware bug in
Host AP mode WDS
wlan0: LinkStatus=2 (Disconnected)
wlan0: LinkStatus=2 (Disconnected)
wlan0: LinkStatus=2 (Disconnected)
wlan0: LinkStatus=2 (Disconnected)
Setting ALC off
Setting TX power to 20 dBm
wlan0: LinkStatus=2 (Disconnected)
wlan0: prism2_open
.............
etc etc etc



----- Original Message -----
From: "Jouni Malinen" <jkmaline at cc.hut.fi>
To: <hostap at shmoo.com>
Sent: Monday, December 16, 2002 4:51 AM
Subject: Re: Problem(s) with a Compaq WL200


> On Sun, Dec 15, 2002 at 04:59:53PM +0000, Adrian McMenamin wrote:
> > On Sunday 15 Dec 2002 4:49 pm, Jouni Malinen wrote:
>
> > > What card and driver are you using as the client that associates with
> > > this AP?
> >
> > On booting, nothing. The client is usually a Prism 2 in managed mode.
But
> > either way it is also impossible to reset the txrate.
>
> And the (client) driver? I would really need to get details to know
> which client cards/firmware versions/drivers are showing this kind of
> behavior to be able to find out the reason for the problems.. If you can
> test the same AP with non-Prism2 card and non-Host AP driver as the
> client, it would be nice to know whether the same problem occurs with
> that station.
>
> --
> Jouni Malinen                                            PGP id EFC895FA
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap
>




More information about the HostAP mailing list