I assume it's not working on linux side

Pierrick Brossin pbrossin at swissgeeks.com
Sat Dec 14 13:52:35 EST 2002


Hey!

I've installed hostap on my machine.
I use hostap_plx with a US.Robotics Adapter and a PCMCIA Card (USR2410).

Here is my problem.
I managed to make hostap work and it work quiet a long time but I had
the bad idea to reboot my server and it won't work anymore.
I can load the module and set the parameters for wlan0 but no PC can
connect to my AP. I've tried with FreeBSD and Windows... I assume it
would be same thing with Linux as client.
btw I have a 2.4.18-5 Kernel...

Here is what I'm doing:

cd /lib/modules/2.4.18-5/net
modprobe hostap_plx
cd /
ifconfig wlan0 10.0.1.1 netmask 255.255.255.0
iwconfig wlan0 channel 11
iwconfig wlan0 mode Master
iwpriv   wlan0 maccmd 1
iwpriv   wlan0 maccmd 4
iwpriv   wlan0 addmac 00:90:XX:XX:XX:XX
iwconfig wlan0 key XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XX
iwconfig wlan0

On the FreeBSD side I made a shell script (which worked perfectly before
the reboot of my Linux server) so I KNOW it's not the problem.

The Mac Address is the one written after 'iwpriv wlan0 addmac' and the
WEP key is the also the same on my FreeBSD laptop and is activated
(wicontrol -k XX.... and then wicontrol -e 1).

I had the same thing once and managed after many hours to make it work
again but I'm not able to find what I've done..

If someone could help I'd really appreciate.

Thanks




More information about the HostAP mailing list