problems with EN2511CD / NL2511CD

dean gaudet dean at arctic.org
Tue Dec 3 01:59:24 EST 2002


On Mon, 2 Dec 2002, Jouni Malinen wrote:

> On Mon, Dec 02, 2002 at 10:00:13PM -0800, dean gaudet wrote:
>
> > Dec  2 20:57:23 mewlark kernel: wlan0: 00:40:96:5a:5d:ce auth (alg=0 trans#=1 stat=0 len=6fc=00b0) ==> 0 (authenticated)
> > Dec  2 20:57:23 mewlark kernel: wlan0: 00:40:96:5a:5d:ce reassoc (len=32 prev_ap=00:03:2f:02:97:46) => 0(0) (OK, new AID)
> >
> > those go on for a while, but the cisco never manages to associate.
> > (i tried a WPC11 as well, no luck either.)
>
> As far as Host AP driver is concerned, that station has been
> successfully associated. However, you could test this with the latest
> CVS version to check whether the station is really acknowledging that
> last reassociation response.

here's what i get with latest CVS:

Dec  2 22:46:42 mewlark kernel: hostap_crypt: registered algorithm 'NULL'
Dec  2 22:46:42 mewlark kernel: hostap_cs: 0.0.0 CVS (Jouni Malinen <jkmaline at cc.hut.fi>)
Dec  2 22:46:42 mewlark kernel: hostap_cs: setting Vcc=33 (constant)
Dec  2 22:46:42 mewlark kernel: hostap_cs: CS_EVENT_CARD_INSERTION
Dec  2 22:46:42 mewlark kernel: prism2_config()
Dec  2 22:46:42 mewlark kernel: hostap_cs: ignoring Vcc=33 (from config)
Dec  2 22:46:42 mewlark kernel: Checking CFTABLE_ENTRY 0x01 (default 0x01)
Dec  2 22:46:42 mewlark kernel: IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
Dec  2 22:46:42 mewlark kernel: io->flags = 0x0046, io.base=0x0000, len=64
Dec  2 22:46:42 mewlark kernel: hostap_cs: index 0x01: Vcc 3.3, irq 3, io 0x0180-0x01bf
Dec  2 22:46:43 mewlark kernel: hostap_cs: Registered netdevice wlan0
Dec  2 22:46:43 mewlark kernel: prism2_hw_init()
Dec  2 22:46:43 mewlark kernel: prism2_hw_config: initialized in 17095 iterations
Dec  2 22:46:43 mewlark kernel: wlan0: NIC: id=0x800c v1.0.0
Dec  2 22:46:43 mewlark kernel: wlan0: PRI: id=0x15 v1.1.0
Dec  2 22:46:43 mewlark kernel: wlan0: STA: id=0x1f v1.4.9
Dec  2 22:46:43 mewlark kernel: wlan0: defaulting to bogus WDS frame as a workaround for firmware bug in Host AP mode WDS
Dec  2 22:46:43 mewlark kernel: wlan0: LinkStatus=2 (Disconnected)
Dec  2 22:46:43 mewlark kernel: Setting ALC off
Dec  2 22:46:43 mewlark kernel: Setting TX power to 24 dBm
Dec  2 22:46:43 mewlark kernel: wlan0: LinkStatus=2 (Disconnected)
Dec  2 22:46:43 mewlark kernel: wlan0: LinkStatus=2 (Disconnected)
Dec  2 22:46:43 mewlark kernel: wlan0: prism2_open
Dec  2 22:46:51 mewlark kernel: wlan0: 00:40:96:5a:5d:ce auth (alg=0 trans#=1 stat=0 len=6 fc=00b0) ==> 0 (authOK)
Dec  2 22:46:51 mewlark kernel: wlan0: 00:40:96:5a:5d:ce auth_cb - frame was not ACKed
Dec  2 22:47:27 mewlark kernel: wlan0: 00:40:96:5a:5d:ce auth (alg=0 trans#=1 stat=0 len=6 fc=00b0) ==> 0 (authOK)
Dec  2 22:47:27 mewlark kernel: wlan0: 00:40:96:5a:5d:ce auth_cb - frame was not ACKed

and just for kicks, here's what happens when i use my older WPC11
card as AP on current CVS (which is working fine):

Dec  2 22:48:05 mewlark kernel: hostap_crypt: registered algorithm 'NULL'
Dec  2 22:48:05 mewlark kernel: hostap_cs: 0.0.0 CVS (Jouni Malinen <jkmaline at cc.hut.fi>)
Dec  2 22:48:05 mewlark kernel: hostap_cs: setting Vcc=33 (constant)
Dec  2 22:48:05 mewlark kernel: hostap_cs: CS_EVENT_CARD_INSERTION
Dec  2 22:48:05 mewlark kernel: prism2_config()
Dec  2 22:48:05 mewlark kernel: hostap_cs: ignoring Vcc=50 (from config)
Dec  2 22:48:05 mewlark kernel: Checking CFTABLE_ENTRY 0x01 (default 0x01)
Dec  2 22:48:05 mewlark kernel: IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
Dec  2 22:48:05 mewlark kernel: io->flags = 0x0046, io.base=0x0000, len=64
Dec  2 22:48:05 mewlark kernel: hostap_cs: index 0x01: Vcc 5.0, irq 3, io 0x0180-0x01bf
Dec  2 22:48:05 mewlark kernel: hostap_cs: Registered netdevice wlan0
Dec  2 22:48:05 mewlark kernel: prism2_hw_init()
Dec  2 22:48:05 mewlark kernel: prism2_hw_config: initialized in 9180 iterations
Dec  2 22:48:05 mewlark kernel: wlan0: NIC: id=0x8002 v1.0.0
Dec  2 22:48:05 mewlark kernel: wlan0: PRI: id=0x15 v0.3.0
Dec  2 22:48:05 mewlark kernel: wlan0: STA: id=0x1f v0.8.3
Dec  2 22:48:05 mewlark kernel: wlan0: defaulting to host-based encryption as a workaround for firmware bug in Host AP mode WEP
Dec  2 22:48:05 mewlark kernel: wlan0: defaulting to bogus WDS frame as a workaround for firmware bug in Host AP mode WDS
Dec  2 22:48:05 mewlark kernel: wlan0: LinkStatus=2 (Disconnected)
Dec  2 22:48:05 mewlark kernel: Setting ALC off
Dec  2 22:48:05 mewlark kernel: Setting TX power to 24 dBm
Dec  2 22:48:05 mewlark kernel: wlan0: LinkStatus=2 (Disconnected)
Dec  2 22:48:05 mewlark kernel: wlan0: LinkStatus=2 (Disconnected)
Dec  2 22:48:05 mewlark kernel: wlan0: prism2_open
Dec  2 22:48:38 mewlark kernel: wlan0: 00:40:96:5a:5d:ce auth (alg=0 trans#=1 stat=0 len=6 fc=00b0) ==> 0 (authOK)
Dec  2 22:48:38 mewlark kernel: wlan0: 00:40:96:5a:5d:ce auth_cb - STA authenticated
Dec  2 22:48:38 mewlark kernel: wlan0: 00:40:96:5a:5d:ce reassoc (len=32 prev_ap=00:03:2f:02:97:46) => 0(0) (OK, new AID)
Dec  2 22:48:38 mewlark kernel: wlan0: 00:40:96:5a:5d:ce assoc_cb - STA associated
Dec  2 22:48:48 mewlark kernel: wlan0: 00:40:96:5a:5d:ce auth (alg=0 trans#=1 stat=0 len=6 fc=00b0) ==> 0 (authOK)
Dec  2 22:48:48 mewlark kernel: wlan0: 00:40:96:5a:5d:ce auth_cb - STA authenticated
Dec  2 22:48:48 mewlark kernel: wlan0: 00:40:96:5a:5d:ce assoc (len=26 prev_ap=00:00:00:00:00:00) => 0(0) (OK, old AID)
Dec  2 22:48:48 mewlark kernel: wlan0: 00:40:96:5a:5d:ce assoc_cb - STA associated

note that prev_ap mac address is the mac address of the WPC11.


> If the client card is not reporting any errors, I would just have to
> guess that it did not like the reassociation reply for some reason (most
> probably it arrived after too long delay). Since the client card sent
> reassociation request, I would assume that it accepted authentication
> frame from the AP (although, I've seen some stations not caring about
> authentication that much..).

the client is win2k / cisco350 ... any idea how i check for errors?

-dean



More information about the HostAP mailing list