Multicast with Linksys PCI WMP11 AP and PCMCIA WPC 11 ver 3

Bichot Guillaume (Princeton) BichotG at tce.com
Mon Dec 2 11:05:13 EST 2002


> 
> On Wed, Nov 27, 2002 at 10:10:14AM -0500, Bichot Guillaume 
> (Princeton) wrote:
> 
> > I'm making some measurement in multicast/broadcast mode having one 
> > server sending some multicast UDP traffic through a Linksys 
> WMP 11 PCI 
> > - Hostap - AP. The client is either the ipaq 3850 under 
> Familiar 0.5.3 
> > or a laptop under Linux redhat 8.0. Both uses a Linksys WPC 
> 11 PCMCIA 
> > card (manfid 0x274, 0x1613).
> > 
> > With the ipaq:
> > The hostap driver simply does not work with the linksys card (it 
> > supposed to work with this card). I got the following error:
> > hostap_cs: card initialization timed out
> > Hostap_cs: initialization failed
> 
> Does the same linksys card work in the laptop? Linksys WPC11 
> Ver3 should work fine with Host AP driver, but I have not 
> tested the latest version of the driver with ARM platform. Do 
> you see any other error messages in the kernel log ('dmesg')?

[Guilaume] Yes the same linksys card works with the laptop. 
It used to work with an old IPAQ though many Tx timeouts(ipaq 3635 , bootldr
2.18.01, Familiar 0.5.3). It does not work with the current one (ipaq 3870,
bootldr 2.18.54, Familiar 0.5.3)
Extra messages are (I do not have dmesg in the ipaq):
Wlan0: hfa384x_set_rid - to BAPA0 failed
hostap_cs: wlan0: resetting card

> 
> > With the laptop:
> > The average association time (i.e. the client detects and 
> associates 
> > with the AP)is 10 seconds between 256 Kbit/s and 1 Mbit/s. With a 
> > 2Mbit/s throughput it becomes impossible to associate with the AP.
> 
> Lot of date traffic in the network will result in association 
> problems since most stations seem to use quite strict limits 
> on how long time receiving of the auth/assoc reply can take. 
> If you upgrade your AP to use latest CVS version, you should 
> be able to see whether the station is acknowledging 
> auth/assoc replies (if not, the delay was probably too long).
> 
> At the moment, the driver does not prioritize outgoing frames 
> at all, but I might need to do this at some point to help 
> association under heavy load. It should help, if the AP would 
> simply by-pass any outgoing queue of data frames when sending 
> auth/assoc replies. There can still be some frames buffered 
> in the wlan card, but at least the host-side queue would not 
> be adding latency. In addition, number of buffered frames in 
> the wlan card could be reduced, if needed.
> 
> > I've tried the iwpriv command to decrease the beacon period 
> but I got 
> > the
> > following: 
> > 
> > # iwpriv wlan0 prism2_param wlan0 beacon_int 1
> > # Interface doesn't accept private ioctl
> > # prism2_param (8BE0): Operation not supported
> 
> That command is not correct. It should be either 'iwpriv 
> wlan0 beacon_int #' or 'prism2_param wlan0 beacon_int #' (if 
> iwpriv/wireless_ext does not support extended iwpriv 
> commands). In addition, you should note that setting beacon 
> interval to 1 would mean that the AP would be sending about 
> 1000 beacons per second in addition to all other traffic and 
> that might already be enough to prevent association..

Thanks. Sure 1 is not exactly the good value.
Currently I'm running wvlan_cs that is the only driver that works with my
ipaq (orinoco_cs does not work). I've constated a 20% packet loss in
multicast whatever the bit rate.

Guillaume
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20021202/e74e1937/attachment.htm 


More information about the HostAP mailing list